Results 1 to 10 of 34

Thread: Windows 7 Walkarounds (Halo 2 for Windows Vista)

Threaded View

  1. #1

    Exclamation Windows 7 Walkarounds (Halo 2 for Windows Vista)

    There are various methods to get Halo 2 for Windows Vista to work on Windows 7 and some work some don't.
    Anyways here is a list of possible solutions below.

    If you are one of the unfortunate players that cannot get Halo 2 to work on Windows 7 please see these methods below.

    Method 1
    DEADBL0W

    Keeping things in perspective, this was never a Games for Windows -- LIVE issue, it was a problem that was addressed like several other products by the Windows development team.

    If you are seeing errors with Halo 2 for Windows Vista, such as 'Failed to Initialize LIVE', then this KB article below should be your next step in resolving your issue. However, if the error still persist, for whatever reason, then you should contact Windows Support for assistance as this update is supported by them.

    http://support.microsoft.com/KB/976264

    As for the manual steps below, they were a spin off from the exact same issue occurring with folks running dedicated servers on Windows Server 2003, they have also been proven to work with Vista and Win 7; However, its a last resort approach and should be avoided unless the above patch fails to resolve your Halo 2 for Windows Vista problems.

    http://support.microsoft.com/kb/941208

    If you continue to experience problems with this error and Halo 2, then you should contact the support number provided in the manual specific to your country.

    Here is the following troubleshooting steps I have done and so far have worked for me and a few friends
    Try the following:
    • 1) Run Command Prompt (run as Administrator):
      2) Type: net stop cryptsvc and hit enter
      3) You will receive a message stating that the service was stopped.
      4) Navigate to your LocalDrive:/Windows/System32 and rename the "catroot2" folder to "cr2old"
      5) Once it is renamed, go back to command prompt and run this command: net start cryptsvc which will restart the Cryptographic Services:


    The above steps may work, however I have noticed that if it does when you exit to the desktop then try to relaunch or reboot the PC the error may come back. If this is true then the steps below have been so far successful.

    • 1) Delete all the tmp*.cat files in the following folders (use the search option on the top right corner of the screen to find and delete the files):
      • %systemroot%\system32\CatRoot\{127D0A1D-4EF2-11D1-8608-00C04FC295EE} (there may be no files in this folder if that’s the case then only worry about the next folder)
      • %systemroot%\system32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} (if no items are found then go to the next step)


      2) Delete all the kb*.cat files in the following folders (use the search option on the top right corner of the screen to find and delete the files):
      • %systemroot%\System32\CatRoot\{F750E6C3-38EE-11D1-85E5-00C04FC295EE} ( A pop up will ask that you need admin rights to delete, accept and delete, you may notice that they were deleted however still appear, if you refresh the screen they will be gone)
      • %systemroot%\System32\CatRoot\{127D0A1D-4EF2-11D1-8608-00C04FC295EE} (again skip if there is no files in the folders)


      3) Delete all the oem*.* files from the %systemroot%\inf folder. (again use the search option on the top right hand corner of the screen to find and delete the files)

      4) At the command prompt (Run as Administrator), type the following commands. Press ENTER after each command.
      • A) net stop cryptsvc
        B) Next, Navigate to your LocalDrive:/Windows/System32 and delete the renamed Catroot2 folder we made previously and keep the “Catroot2” file
        C) ren %systemroot%\System32\Catroot2 oldcatroot2
        D) net start cryptsvc

      5) Exit Command Prompt

      6) Run halo 2


    This should run successfully, even after exiting and re-launching halo 2 as well as after a reboot. Hopefully this helps and Please post back with results, as I'm sure the Mods would like to know the outcome
    Source

    Method 2
    GFWLMod

    Looks like I am going to be giving another nod to our friends over at http://www.monstrmoose.com/ (in particular Squirrely)

    A user has reported that they have a workaround for this, which is very similar to one for Halo2 dedicated servers (http://support.microsoft.com/kb/936688). It does not appear to "fix" the problem persey but it *should* (I cannot test this in house as I have no erroring system) allow you to play, even if you need to do this occasionally. I would like to ask some of our users who are having this issue, to give this a try:

    Run Command Prompt (run as Administrator):

    Type: net stop cryptsvc and hit enter
    You will receive a message stating that the service was stopped. Navigate to your LocalDrive:/Windows/System32 and rename the "catroot2" folder to "cr2old"

    Once it is renamed, go back to command prompt and run this command: net start cryptsvc which will restart the Cryptographic Services:



    Please let me know the results and I will send our devs back to finding the root issue
    Source

    Method 3
    Squirrely765

    This is a followup to my previous post.

    I fairly quickly threw together a program to do the first part of the fix automatically. (Deleting/renaming catroot2)

    *****This program has to be run as an Administrator for it to work properly, or it will throw an error.*****

    If you download and use this program please understand the following below: (I am just doing this as I don't want to hear "this program haxed my pc". Also if you skip the reading below that means you agreed.)

    ------------------------------------------------------------------

    MonstrMoose.com is making this software freely available on the basis that it is accepted as found and that the user checks its fitness for purpose prior to use.

    This software is provided 'as-is', without any express or implied warranties whatsoever. In no event will the authors, partners or contributors be held liable for any damages, claims or other liabilities direct or indirect, arising from the use of this software.

    MonstrMoose.com gives permissions to redistributing this program freely, but to use this software you must agree to the following restrictions:

    1. The origin of this software must not be misrepresented; you must not claim that you wrote the original software.
    2. You must not alter the software in any way.
    3. This notice may not be removed or altered from any distribution.
    4. You may not resell or charge for the software.
    5. You may not reverse engineer, decompile, disassemble, derive the source code of or modify [or create derivative work from] the program.
    6. You must not use this software to engage in or allow others to engage in any illegal activity.
    7. You may not claim any sponsorship by, endorsement by, or affiliation with MonstrMoose.com if you use this program.
    8. You acknowledge that MonstrMoose.com owns all the code and research for this said program.

    Additional Info:

    This program *does* delete a folder (catroot2) in your Windows directory. It logs everything it does in the text-box. This program's only use is to attempt to fix the Windows 7 problem with H2V and nothing else.

    ------------------------------------------------------------------

    So finally, here is the link to download it.

    http://www.monstrmoose.com/download....H2VWin7Fix.exe

    Please post any problems you had with it.
    Source

    Method 4
    Shock120
    • 1) Do these steps first.
      • Download the latest H2V update
      • Download the latest GFWL update
      • Install them both


      2) Navigate to root folder you installed Halo 2 on.
      • Default 32bit OS: C:\Program Files\Microsoft Games\Halo 2
      • Default 64bit OS: C:\Program Files (x86)\Microsoft Games\Halo 2


      3) move "activate.exe" to another location. (it can be anywhere, preferably the desktop)
      4) Start up halo2.exe (which is in the Halo 2 folder)
      5) Sign onto GFWL
      • when prompted for a product key from GFWL, enter it as such.
      • After entering the Product key, you will see Live and Network still grayed out.
      • Close H2V.


      6) Bring "activate.exe" back into the Halo 2 folder.

      7) Initiate Startup.exe
      • you will be prompted for a key, enter it, then enjoy H2V!


    This fixed my problem, I was comparing what file from 1.0 and 1.4 of H2V is messed up.
    THIS SOLVED MY UNSOLVABLE CRYPTOGRAPHIC CRAP, that GFWL couldn't solve.
    Source

    Method 5
    Guardian Hope
    IdahoLagold

    For those with the "Live Gaming on Windows failed..." problem. I have Windows 7, 64-bit and was having trouble for weeks. I read many forums and thanks to Deadblow, I was able to finally run the game. However, upon reboot I received the blue screen and had to revert to an earlier time. But buried deep within this long string of replies are two postings. One is from Selexo and one is from "The Double Duce". I followed their advice and now I think the game is totally stable on my system. Basically, all I needed to do was to remove (or rename) these two files from the Inf folder: oem94.inf and oem95.inf.

    As they already reported, this may be different on other computers, but for MY computer, after deleting these, everything worked. It will be different for your computer! You need to go through a trial and error exersize. Such as: I started by installing the game completely and then moving all the oem*.* files from the INF folder into a new folder. Then the game would start. But to narrow it down to the one or two bad files, I needed to cut and past and keep re-starting the game until I figured out which files were the offenders.

    Again, thanks Deadblow, Selexo and Double Duce. Your hard work paid off for me. I was even able to transfer all my saved games from another computer, but that's another story.
    I had the same problem as you. After reading your post I went to C:\Windows\INF and started by coping the second half of my OEM files (including both the .INF and .PNF files). By narrowing it down via the process of elimination I have resolved my problem. For me, it was OEM20.inf and OEM20.pnf which are for atiilhag.inf and there is a special note that it was modified with Mobility Modder.NET (Previous to Catalyst 10.3 we Notebook users had to use that utility to get updated drivers to work). Now Halo 2 works fine and my system seems perfectly fine. I did not do anything to my Catroot folders or any other modification besides what I said above and also listed below to get Halo 2 to work on my Windows 7 Ultimate x64 System.

    So, to narrow it down:

    Problem: LIVE Gaming for Windows fails to initialize on some Windows 7 systems running Halo 2 Vista.

    Symptoms: When starting Halo 2 Vista, an error will pop up stating that "LIVE Gaming for Windows failed to initialize..."

    Solution: This error seems to be caused by one or more OEM files in the C:\Windows\INF directory. You will need to narrow down which file (or files) it is by moving them to another directory and starting Halo 2 to see if it starts. If it does, you need to move some of the OEM files back until you get the error, then narrow it down to the one or multiple files causing it. Remember, it will not be the same file on all systems as the post I have quoted had the problem with OEM94.inf and OEM95.inf which don't even exist on some systems.

    Good luck, and I hope this helps!

    Selexo 1
    Selexo 2
    Selexo 3
    The Double Duce 1
    The Double Duce 2
    Source

    Method 6
    xxFFernandoxx
    This video is unable to be displayed because the YouTube video tags were used incorrectly. Please review proper use of the tags here.
    Source

    Method 7
    PirateOfTheInternet
    This video is unable to be displayed because the YouTube video tags were used incorrectly. Please review proper use of the tags here.
    Source

    Method 8
    Quote Originally Posted by Vicky
    Hi. Recently finally installed Win7 and just for old time sakes i figured to install h2v.. right... easier than it sounded. I PM this so you can edit your post, i don't think i've seen any link to what i installed.. did work though.

    1st did the regular downloads, update.exe, gfwlivesetup.exe. When i ran GFW it started nagging about a Live sign-in assistant, right available for download.. so far so good but the thing wllogin_64.msi wouldn't install no matter what.
    Got me this package: http://www.microsoft.com/downloads/e...d-8745be104600 and h2v worked right away.

    L8r!
    Source: Private Message from Vicky

    Method 9
    Syuusuke
    If all else fails, install a new partition with Windows 7 (or over your old one) and try it.

    It should work, eventually it worked for me. It turned out the cryptographic service was off for me because it "logged" on as the Local System instead of Local Service, which was later changed to Network Service... (this was a special case )
    Source
    Last edited by supersniper; July 21st, 2014 at 02:48 AM. Reason: updating
    Reply With Quote

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

     

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts